Connexion

Récupérer mon mot de passe

Derniers sujets
» histoire du Jour sans fin
par Quad Daniel Hier à 7:38

» *RESOLU*[Edge] Customiser les boutons "Répondre" et "Nouveau sujet"
par Milouze14 Mar 17 Sep 2019 - 15:59

» [TOUTES VERSIONS] Afficher les outils de modération via la liste des sujets
par Splash Dim 15 Sep 2019 - 20:08

» *CORBEILLE*[AwesomeBB] Afficher le texte pour les champs du contact
par Milouze14 Dim 15 Sep 2019 - 19:20

» *RESOLU*[Edge] Ajouter l'année sur les posts
par Milouze14 Dim 15 Sep 2019 - 17:22

» *RESOLU*[Edge] Arrondir les angles du forum
par Milouze14 Sam 14 Sep 2019 - 19:05

» [AwesomeBB]Afficher les boutons " éditer, citer, supprimer, etc ... " sous forme de texte
par Milouze14 Sam 14 Sep 2019 - 7:35

» [Edge]Afficher les boutons " éditer, citer, supprimer, etc ... " sous forme de texte
par Milouze14 Sam 14 Sep 2019 - 6:36

» [ModernBB]Afficher les boutons " éditer, citer, supprimer, etc ... " sous forme de texte
par Milouze14 Sam 14 Sep 2019 - 6:25

» [Invision]Afficher les boutons " éditer, citer, supprimer, etc ... " sous forme de texte
par Milouze14 Sam 14 Sep 2019 - 5:32

» [PhpBB3]Afficher les boutons " éditer, citer, supprimer, etc ... " sous forme de texte
par Milouze14 Sam 14 Sep 2019 - 5:13

» [PunBB]Afficher les boutons " éditer, citer, supprimer, etc ... " sous forme de texte
par Milouze14 Sam 14 Sep 2019 - 4:57

» [PhpBB2]Afficher les boutons " éditer, citer, supprimer, etc ... " sous forme de texte
par Milouze14 Sam 14 Sep 2019 - 4:55

» [EDGE] Afficher/Masquer les catégories avec un effet
par chrisnvidia Ven 13 Sep 2019 - 22:17

» *RESOLU*[AwesomeBB] Afficher le bouton nouveau selon les permissions
par Milouze14 Jeu 12 Sep 2019 - 3:54

» [Toutes versions] Utiliser les variables utilisateur/forum
par fascicularia Jeu 12 Sep 2019 - 3:20

» *RESOLU*[Edge] Afficher les derniers tutoriels en ligne
par Milouze14 Mar 10 Sep 2019 - 11:26

» Règlement de l'entraide Forumactif
par chrisnvidia Lun 9 Sep 2019 - 21:23

» *RESOLU*[ModernBB] Intégrer une boîte défilante d'EmojiOne dans l'éditeur
par Milouze14 Lun 9 Sep 2019 - 19:46

» *RESOLU*[Edge] Afficher les derniers sujets
par Milouze14 Lun 9 Sep 2019 - 11:51

*RESOLU* [EDGE] Trop de personnalisation tue la personnalisation ?

Voir le sujet précédent Voir le sujet suivant Aller en bas

Splash
Splash
Milouzien

MessageSplash le Mar 2 Oct 2018 - 16:27

Hi,

Je rencontre un gros soucis d'affichage qui semble être lié avec mon compte Admin

Voici comment je vois le bas de page en mode offline

*RESOLU* [EDGE] Trop de personnalisation tue la personnalisation ? Bas_de10

Et voici ce même bas de page en mode online

*RESOLU* [EDGE] Trop de personnalisation tue la personnalisation ? Bas_de11

Tout est complétement décalé, et ce avec 3 navigateurs différents, Opéra, Firefox et Chrome
J'ai testé avec un compte membre et je n'ai pas ce souci

J'ai vidé le cache de mon navigateur, vidé les cookies, désactivé les scripts mais le soucis persiste

Ce problème est apparu ce matin à la création d'un groupe Modo et en nommant un nouvel inscrit, que je connais d'un autre forum, en tant que Modo


Je remarque aussi un autre bug, lié au message de remerciement
En prévisualisant les messages avant l'envoie j'ai systématiquement cette inscription :

*RESOLU* [EDGE] Trop de personnalisation tue la personnalisation ? Messag10

La phrase qui apparaît après la signature. Ce problème existe aussi avec le compte de test membre

Mais le pire reste cet affichage en remerciant un membre pour son post :

*RESOLU* [EDGE] Trop de personnalisation tue la personnalisation ? Visu_d10

Là c'est la cerise sur le gâteau !

D'où cela peut-il bien venir ?

EDIT

J'ai aussi ce problème de décalage dans les messages

*RESOLU* [EDGE] Trop de personnalisation tue la personnalisation ? Dzocal10

Ce décalage apparaît à partir du 8e message dans un sujet


Dernière édition par Splash le Mar 2 Oct 2018 - 19:48, édité 1 fois
Milouze14
Milouze14
Fondateur

MessageMilouze14 le Mar 2 Oct 2018 - 18:50

Hello Fred,

un sujet = une demande  clin oeil .

Je n'ai pas ce soucis sur ton fofo quelque soit le navigateur sur l'affichage du qeel.
Quelle relation pourrait engendrer ce dysfonctionnement avec ton compte Admin ?

Je viens de tester le message de remerciement et effectivement le premier message se retrouve avec tous les messages ?????

Tu as changé le script ?
Splash
Splash
Milouzien

MessageSplash le Mar 2 Oct 2018 - 19:01

On dit souvent que les soucis informatique se situent entre le siège et le clavier !
J'ai résolu mon soucis pour le qeel, cela venait d'une erreur d'un titre de sous-forum dans une partie du forum non visible aux membres.

Pour le message de remerciement, comme tu as pu le constater, est récurent à chaque fois que la balise center est utilisée, et le message que tu as remercié en est gavé de ces balises

Les seuls modifs que j'ai fait au script c'est au sujet des textes

Le script modifié :

Code:
$(function(){
if (_userdata["user_id"] >= (0)){
var M14_author=_userdata["username"];
$('.post:eq(0)').addClass('M14_No_Thank').each(function(){
$(this).find('.content div').after('<div class="M14_Thank_Cont"><div><span class="M14_Texte_liste">Ce membre te dit merci</span><span class="M14_ThankUser"></span> pour ce topic : <a target="_blank" href="" class="M14_Thank_link"></a><br /></div><div class="M14_Thank_list"><div></div></div></div>');
var M14_Thank_text=$(this).find('.topic-title').text();
var M14_Thank_link=$(this).find('.topic-title').attr('href');
var M14_UserPost=$(this).find('.postprofile .username a[href^="/u"]').text();
var M14_UserPostColor=$(this).find('.postprofile .username span').css('color');
$('.M14_Length').closest('.post').addClass('M14_Ok_Thank');
if(M14_author!=M14_UserPost)
{
$(this).find('ul.profile-icons li:first').before('<li><a id="M14_Thank"class="color-primary"title="Remercier l\'auteur(e) du topic"></a></li>');
}
if($('.M14_Ok_Thank').length)
{
$('.post:eq(0)').find('.M14_Thank_Cont').show();
};

$('.M14_ThankUser').css('color',M14_UserPostColor).text(''+M14_UserPost+'');
$('a.M14_Thank_link').attr('href',M14_Thank_link).text(''+M14_Thank_text+'');
});

}

});

$(function() {

$('.M14_Ok_Thank').each(function(){
var M14_User_thank=$(this).find('.author a[href^="/u"]').html();
var M14_UserNull=$('.M14_Ok_Thank').length <2;
var M14_UserMore=$('.M14_Ok_Thank').length >1;
if(M14_UserNull)
{
$('.M14_Thank_list div').append(''+M14_User_thank+'');

else if(M14_UserMore)
{
$('.M14_Thank_list div').append(''+M14_User_thank+'');
$('.M14_Texte_liste').html('Ces membres te remercient')
}
});
$('.post:not(.M14_No_Thank)').each(function(){
var M14_author=_userdata["username"];
$('.M14_Thank_list div strong').each(function(){
var $this=$(this).text();
if($this==M14_author)
{
  $('#M14_Thank').replaceWith('<a id="M14_ThankThank"class="color-primary"title="Tu as déjà dit merci pour ce topic"></a>');
}
});});
 
});
$(function() {
// ON RENSEIGNE LE TEXTE CI DESSOUS
var texte="<div class=M14_Length>Merci beaucoup !</div>";
var message=texte;
$('#M14_Thank').click(function() {
$editor = $('.sceditor-container');
if ($editor.hasClass('wysiwygMode')) $editor.removeClass('wysiwygMode').addClass('sourceMode') ;
$('#quick_reply textarea ').val(message);
$('input[name="post"]').click();
});
});
Milouze14
Milouze14
Fondateur

MessageMilouze14 le Mar 2 Oct 2018 - 19:05

Oki,
pour les tags, le script a été placé sur les sujets ou sur toutes les pages?
Je vais retenter de poster sur la présentation de David1195 pour voir le soucis
Splash
Splash
Milouzien

MessageSplash le Mar 2 Oct 2018 - 19:07

Le script est sur toutes les pages
Milouze14
Milouze14
Fondateur

MessageMilouze14 le Mar 2 Oct 2018 - 19:20

Oki merci,
j'ai trouvé l'erreur, en fait lorsque le membre dépose une balise center , une fois posté cela se transforme en balise div.

Dans le script recherches ceci:
Code:

$(this).find('.content div').after('<div id="M14_Thank_Cont"cla

Remplaces
Code:
.content div
Par
Code:
.content div:first

Splash
Splash
Milouzien

MessageSplash le Mar 2 Oct 2018 - 19:24

Hum, OK
Tu avais déjà fait une modif à ce niveau là, rajouter un div après .content si je ne m'abuse
Milouze14
Milouze14
Fondateur

MessageMilouze14 le Mar 2 Oct 2018 - 19:27

Oui mais il faut ajouter :first à cette div
Splash
Splash
Milouzien

MessageSplash le Mar 2 Oct 2018 - 19:29

Je sais, c'est fait
Splash
Splash
Milouzien

MessageSplash le Mar 2 Oct 2018 - 19:34

Mais y'a tout de même un truc pas claire avec ce système

Je viens de faire un essaie de prévisualisation et le message de remerciement apparaît toujours, c'est pas normal je suppose ?

*RESOLU* [EDGE] Trop de personnalisation tue la personnalisation ? Dit10

Tu ne remarque pas ça toi sur ce forum puisque tu as installé ce système de merci ?
Milouze14
Milouze14
Fondateur

MessageMilouze14 le Mar 2 Oct 2018 - 19:42

Non, tu as édité ton propre message, et il est logique que puisses voir le contenu du
script sans pour autant avoir le nom du membre.
Le script est prévu pour remercier et non éditer Fred
Splash
Splash
Milouzien

MessageSplash le Mar 2 Oct 2018 - 19:44

OK dans ce cas c'est logique. Merci à toi

Pour mon problème de taille de message à partir du 8ième j'ouvre un autre topic ?
Milouze14
Milouze14
Fondateur

MessageMilouze14 le Mar 2 Oct 2018 - 19:45

Oui je préfère Fred clin oeil
Splash
Splash
Milouzien

MessageSplash le Mar 2 Oct 2018 - 19:47

OK je clos
Milouze14
Milouze14
Fondateur

MessageMilouze14 le Mar 2 Oct 2018 - 19:49

-Staff du Forum Milouze14-



  • Hello 
    Sujet résolu et déplacé dans le forum adéquat.

Pour toute information,merci de contacter un Membre du Staff

Voir le sujet précédent Voir le sujet suivant Revenir en haut

Créer un compte ou se connecter pour répondre

Vous devez être membre pour répondre.

S'enregistrer

Rejoignez notre communauté ! C'est facile !


S'enregistrer

Connexion

Vous êtes déjà membre ? Aucun soucis, cliquez ici pour vous connecter.


Connexion

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum