Connexion

Récupérer mon mot de passe

Derniers sujets
» [PhpBB2] Effet transition icône du forum
par petitefeuille Aujourd'hui à 8:57:45

» [PhpBB3] Miniature agrandie sur réponse rapide
par Milouze14 Aujourd'hui à 4:16:46

» [PhpBB2] Ouverture d'une balise object ou iframe au clic sur un bouton
par fascicularia Hier à 21:48:12

» [PhpBB2] positionnement css
par Milouze14 Lun 18 Nov - 17:50:38

» histoire du Jour sans fin
par Quad Daniel Lun 18 Nov - 7:28:32

» *RESOLU*[PhpBB2] Notifications Push
par Milouze14 Lun 18 Nov - 6:06:08

» *RESOLU*[PhpBB2] Modifier la toolbar
par Milouze14 Lun 18 Nov - 6:03:37

» [PHPBB2] Menu Rechercher en haut à gauche effet survol
par HardRock Sam 16 Nov - 21:23:45

» *RESOLU*[PhpBB3] Couleur de lien dans les messages
par Milouze14 Sam 16 Nov - 19:04:13

» *CORBEILLE*[PhpBB2] avertissement lors de la publication d'un email 2 le retour
par Milouze14 Sam 16 Nov - 7:16:02

» [PhpBB2]Module de connexion type forumactif
par petitefeuille Jeu 14 Nov - 13:12:19

» Règlement de l'entraide Forumactif
par msfeettoes Mer 13 Nov - 17:28:47

» *RESOLU*[PhpBB3] Retirer bouton contact aux invités
par Milouze14 Mer 13 Nov - 15:59:10

» [PhpBB2] Avertissement lors de la publication d'un email
par Milouze14 Mer 13 Nov - 3:53:57

» *RESOLU*[PhpBB2] Annonce Google décalée
par Milouze14 Lun 11 Nov - 21:08:42

» [PhpBB2] Ajouter à vos favoris
par Milouze14 Lun 11 Nov - 18:22:52

» [PhpBB2] Changer le nom d'un groupe
par petitefeuille Lun 11 Nov - 15:53:20

» *RESOLU*[Edge] Bannière defilante
par Milouze14 Lun 11 Nov - 8:57:20

» *RESOLU*[PhpBB3] Bouton uniquement sur premier post
par Milouze14 Dim 10 Nov - 19:19:04

» *RESOLU*[PhpBB3] Photos par thèmes
par Milouze14 Dim 10 Nov - 17:51:40

*RESOLU* [PHPBB2] Souci sur un tag

Voir le sujet précédent Voir le sujet suivant Aller en bas

Sacha
Sacha
Milouzien

MessageSacha le Sam 6 Oct - 2:50:06

Hello Phil,

J'ai un petit souci que je ne parviens pas à résoudre Phil. J'espère que tu pourras m'aider à résoudre le problème.



Sur la capture écran ci-dessus, tu remarqueras que sur le premier message (Un message édité) que je suis ennuyé avec 2 br gênants !

Tu remarqueras sur cette même image sur le deuxième message qui n'a jamais été édité les traces du padding que j'ai placé dans le CSS servant sur le texte du message édité "Dernière édition par Mastermix le Ven 5 Oct 2018 - 23:53, édité 3 fois" Puisque ce deuxième message n'a jamais été édité, il ne devrait même pas avoir cette trace !

Template viewtopic_body : Ligne 219

Code:
<span class="editmess">{postrow.displayed.EDITED_MESSAGE}</span>

Dans l'inspection du navigateur :

Code:
<span class="editmess"><br><br>Dernière édition par Mastermix le Ven 5 Oct 2018 - 23:53, édité 3 fois</span>

Css associé à la class editmess

Code:
.editmess {
background-color:#8b0000;
color:#fff !important;
padding: 3px;
}

Sur la capture écran ci-dessous Phil, sur le premier message, donc, celui qui a été édité 3 fois, qu'une fois que je supprime les 2 br dans l'inspection des éléments du navigateur cela reviens à la normale.

Après suppression des 2 br dans l'inspection des éléments du navigateur

Code:
<span class="editmess">Dernière édition par Mastermix le Ven 5 Oct 2018 - 23:53, édité 3 fois</span>

Cependant sur le deuxième message, celui qui n'a jamais été édité, il garde les traces du padding alors qu'il ne devrait rien y avoir du tout !



Donc Phil, est-ce possible de faire en sorte de supprimer les 2 br gênants du tag ci-dessous ?

Code:
{postrow.displayed.EDITED_MESSAGE}

Et qu'il ne garde pas de trace du padding placée pour le texte en cas d'édition du message quand un message n'est pas édité ?

Si tu vas sur mon forum Phil, le template viewtopic_body n'est pas publié et pour voir utilise le sujet "teste sur un sujet dans liste des sujets"

Merci pour ton aide.

Sacha.


Dernière édition par Sacha le Mer 10 Oct - 15:56:39, édité 1 fois
Milouze14
Milouze14
Fondateur

MessageMilouze14 le Sam 6 Oct - 6:10:23

Hello Sacha,
tu as déposé la variable qui gère les messages des éditions dans un span, et cette balise n'est pas réellement conçue pour recevoir un contenu.
J'ai donc remplacé par une div et revu le style de cette dernière en déposant un display:inline-flex.

Code:
<div class="editmess"style="margin-top:4px;display: inline-flex;">{postrow.displayed.EDITED_MESSAGE}</div>

Puis le script ajouté dans la gestion des scripts:
Code:
//On supprime le padding si pas d'édition
$(function(){
$('.editmess').each(function(){
if($('.editmess:empty').length)
{
$('.editmess:empty').css('padding','0px');
};
});});

Qui supprimera le padding si le message n'a pas était édité clin oeil
Sacha
Sacha
Milouzien

MessageSacha le Sam 6 Oct - 17:00:53

Hello Phil,

Cela ne va pas trop bien Phil regarde la capture ci-dessous.



En appliquant une hauteur et une marge left, j'arrive à cela :



Code:
.editmess {
background-color:#8b0000;
color:#fff !important;
padding: 3px;
height: 14px;
margin-left: 5px;
}

Le problème maintenant, c'est qu'il m'est impossible de remonter le texte seul dans l'encadrement rouge pour faire comme par exemple sur l'image ci-dessous



aurais-tu une solution ? Parce que là dans l'état actuel je ne peux pas conserver cela ainsi.

Merci pour ton aide.

Sacha.


Milouze14
Milouze14
Fondateur

MessageMilouze14 le Sam 6 Oct - 20:39:54

Hello Sacha,
j'ai modifié le style de cette balise:

Code:
.editmess {
background-color:#8b0000;
color:#fff !important;
padding: 3px;
height: 14px;
margin-left: 5px;
line-height: 3px;
margin-top:4px;
float:left;
}

Tout est ok désormais hinhin
Sacha
Sacha
Milouzien

MessageSacha le Sam 6 Oct - 21:02:14

Re Phil,

Bien vu Phil, je n'aurais jamais pensé à utiliser le float et line height en supprimant le display: inline-flex

Bête question, cela ne fonctionne que sur le premier poste ? Parce que j'ai voulu voire sur le deuxième poste, mais il ne notifie pas que le poste a été éditer comme celle du dessus !



Milouze14
Milouze14
Fondateur

MessageMilouze14 le Dim 7 Oct - 5:10:56

Hello Sacha,
cela fonctionne sur tous les messages sauf le dernier Sacha clin oeil .
Sacha
Sacha
Milouzien

MessageSacha le Dim 7 Oct - 11:27:42

Hello Phil,
Bizarrement, pas de mon côté, J'ai pourtant vidé le cache et les cookies et même essayé avec le navigateur Edge ! Mon navigateur Google Chrome est à jour sur la Version 69.0.3497.100 (Build officiel) (64 bits)

Milouze14
Milouze14
Fondateur

MessageMilouze14 le Dim 7 Oct - 12:03:30

Le soucis est réglé Sacha,
@Milouze14 a écrit:
Hello Sacha,
cela fonctionne sur tous les messages sauf le dernier Sacha clin oeil .

A moins que l'on ne se comprenne pas!!!
fascicularia
fascicularia
Milouzien

Messagefascicularia le Lun 8 Oct - 13:07:14

Bonjour SACHA,
Philippe sera absent toute la semaine pour des raisons familiales.
Sacha
Sacha
Milouzien

MessageSacha le Mer 10 Oct - 15:56:22

Hello Fascicularia,

Je comprends pas de souci.

Je vais clore ce sujet et ouvrir un autre et peut-être que tu pourras m'aider sur le système de Messenger qui n'a pas l'aire de vouloir marcher lol

Sacha.
Jackymi
Jackymi
Milouzien

MessageJackymi le Mer 10 Oct - 17:19:22


Coucou

Sujet résolu et déplacé dans le forum adéquate

A bientôt pour une prochaine demande clin oeil

Voir le sujet précédent Voir le sujet suivant Revenir en haut

Créer un compte ou se connecter pour répondre

Vous devez être membre pour répondre.

S'enregistrer

Rejoignez notre communauté ! C'est facile !


S'enregistrer

Connexion

Vous êtes déjà membre ? Aucun soucis, cliquez ici pour vous connecter.


Connexion

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum