Aperçu du thème X
Connexion

Récupérer mon mot de passe

Derniers sujets
» *RESOLU*[PHPBB3] Cadre des messages dans un sujet
par Milouze14 Aujourd'hui à 18:43

» [BESTOF] Supprimer le qui est en ligne sur la droite
par Milouze14 Aujourd'hui à 10:14

» *RESOLU*[PHPBB3] Message au dessus de l'éditeur
par Milouze14 Hier à 11:56

» *RESOLU*[PHPBB2] Fenetres en haut du forum suite
par Milouze14 Mar 31 Mar 2020 - 19:39

» *RESOLU*[PHPBB3] Smiley dans miniatures
par Milouze14 Sam 28 Mar 2020 - 18:23

» [PHPBB2] Petites précisions script remplace terme invité
par Milouze14 Sam 28 Mar 2020 - 18:22

» [PHPBB2] Remplacer le mot Invité
par Mi Neth Sam 28 Mar 2020 - 14:42

» [TOUTES VERSIONS] Edition rapide
par Mi Neth Ven 27 Mar 2020 - 13:05

» [TOUTES VERSIONS] Recherche de texte dans les templates
par Mi Neth Jeu 26 Mar 2020 - 17:07

» [PHPBB3] Cacher les boutons citer et multi-citation pour un membre spécifique
par Milouze14 Jeu 26 Mar 2020 - 15:53

» [PHPBB2] Descendre des infos dans le profil simple,
par Milouze14 Mar 24 Mar 2020 - 15:26

» [PHPBB2] Modifier un menu section membres
par Milouze14 Sam 21 Mar 2020 - 15:06

» *RESOLU*[PHPBB3] Modifier couleur titre de colonne dans les catégories
par Milouze14 Ven 20 Mar 2020 - 18:33

» *RESOLU*[PHPBB3] Miniatures sur profil
par Milouze14 Ven 20 Mar 2020 - 18:30

» *RESOLU*[PHPBB2] Message automatique au déplacement d'un sujet
par Milouze14 Ven 20 Mar 2020 - 11:22

» *RESOLU*[PHPBB3] Bouton Favoris sous l'avatar
par Milouze14 Dim 15 Mar 2020 - 5:57

» *RESOLU*[PHPBB3] Bouton photos dans Phototest
par Milouze14 Dim 15 Mar 2020 - 5:56

» [AWESOMEBB] Ajouter son copyright
par christ77000 Jeu 12 Mar 2020 - 14:30

» [PHPBB2] Menu déroulant et Profil Rechercher et Nouveau M.P séparé
par Ptite_Perle Mer 11 Mar 2020 - 18:28

» [PHPBB2]Afficher les statistiques dans la liste des membres
par christ77000 Mer 11 Mar 2020 - 16:26

*RESOLU*[PhpBB2] Script qui beug depuis plusieurs jours

Voir le sujet précédent Voir le sujet suivant Aller en bas

fascicularia
fascicularia
Milouzien

Messagefascicularia le Mar 15 Oct 2019 - 17:05

  • Version du forum :
    PhpBB2
  • Templates modifiés :
    oui
  • Navigateur :
    Opera
Bonjour à tous, 
suite à une demande de Photoclic, Philippe nous avait concocté un script qui permet d'afficher la première image contenue dans un sujet au niveau des sous forums.

Hélas, depuis quelques jours, le script n'affiche désormais que l'image par défaut.

le js
Code:
//Aperçu des images
$(function(){$('a.nav[href^="/f67-"],a.nav[href^="/f74-"],a.nav[href^="/f66-"],a.nav[href^="/f63-"],a.nav[href^="/f14-"],a.nav[href^="/f4-"]').length&&($(".M14_LoaD_ToPiCsConT").after('<a href="#" style="margin-left: 5px;" class="M14_LoaD_ToPiCs"><img src="https://i.servimg.com/u/f11/11/93/85/24/images10.jpg"/></a>'),$(".M14_LoaD_ToPiCs").each(function(){
var b=$(this).find("img"),a=$(this).closest("tr").find("a.topictitle").text(),c=$(this).prev().attr("href");
$(this).attr("href",c).attr("title",a);
a=$(this).prev().attr("href");
$.get(a,function(a){(a=$(a).find(".postbody:first div:first img:not([longdesc]):first").filter(function(){return this.width>100&&this.height>100;}).attr("src"))&&b.attr("src",a)})}))});

le visuel actuel
*RESOLU*[PhpBB2] Script qui beug depuis plusieurs jours Pour_p10

la séquence d'un sujet sur lequel l'image devrait apparaître
Code:
<tr class="M14_anim"><td class="row1" align="center" valign="middle" width="20"><img src="https://i.servimg.com/u/f39/11/93/85/24/sans_t27.png" alt="Pas de nouveaux messages" class="tooltipstered"></td><td class="row2" align="center" valign="middle" width="20"><img align="middle" src="https://illiweb.com/fa/empty.gif" alt="~Aracées~ Empty"></td><td class="row2" onmouseover="this.className="row2"" onmouseout="this.className="row2"" width="100%"><a class="M14_LoaD_ToPiCsConT" href="/t4273-colocasia-esculenta-indetermine-colocasia-mammoth"></a><a href="/t4273-colocasia-esculenta-indetermine-colocasia-mammoth" style="margin-left: 5px;" class="M14_LoaD_ToPiCs tooltipstered"><img src="https://i.servimg.com/u/f11/11/93/85/24/images10.jpg"></a><div class="topictitle"><img src="https://illiweb.com/fa/empty.gif" alt="Vous avez posté dans ce sujet." class="tooltipstered">  <h2 class="topic-title"><p class="M14_first-letter;margin-top:20px; "><a class="topictitle" href="/t4273-colocasia-esculenta-indetermine-colocasia-mammoth">Colocasia esculenta indéterminé (colocasia Mammoth ?)</a>     </p></h2></div><div class="mod_tools"><img src="https://i.servimg.com/u/f39/11/93/85/24/sans_t27.png" alt="Pas de nouveaux messages" style="display:none;"></div><span class="gensmall"></span>&nbsp;<span class="gensmall"></span></td><td class="row2" align="center" valign="middle"><span class="postdetails">12</span></td><td class="row3" align="center" valign="middle"><span class="name"><strong><a href="/u1">fascicularia</a></strong></span></td><td class="row2" align="center" valign="middle"><span class="postdetails">673</span></td><td class="row3Right" onmouseover="this.className="row1"" onmouseout="this.className="row3Right"" align="center" valign="middle" nowrap="nowrap"><div style="width: 250px;"></div><span class="lastpost-avatar"><img src="https://7img.net/users/3412/61/21/12/avatars/1-73.jpg" alt="~Aracées~ 1-73"></span><span class="postdetails">le Dim 1 Sep 2019 - 20:23<br><strong><a href="/u1" class="gensmall">fascicularia</a></strong> <a href="/t4273-colocasia-esculenta-indetermine-colocasia-mammoth#38258"><img src="https://illiweb.com/fa/empty.gif" alt="Voir le dernier message" class="tooltipstered"></a><a title="Actions de modération" class="ipsModMenu" href="#"> </a></span></td></tr>

un lien d'un forum sur lequel le scriptp devrait agir
https://altitudetropicale.forums-actifs.com/f3-aracees

f3 et un sous forum de f67

si vous voyez  ce qui cloche !!! Je soupçonne un dysfonctionnement lié aux dernières modif de fa sur les images (à moins que je ne sois mauvaise langue 😊)

Merci par avance pour votre aide.

ps : rien de bien pressant (là aussi, c'est de la fioriture)


Dernière édition par fascicularia le Mar 15 Oct 2019 - 19:42, édité 1 fois
Milouze14
Milouze14
Fondateur

MessageMilouze14 le Mar 15 Oct 2019 - 17:54

Coucou Stéphane,
ce script a été revu?Car je ne code pas ainsi!!

Je vais tester sur ton fofo en modifiant quelque peu ce dernier.
fascicularia
fascicularia
Milouzien

Messagefascicularia le Mar 15 Oct 2019 - 19:12

Bonjour Philippe,
c'est sympa mais rien ne presse.
Milouze14
Milouze14
Fondateur

MessageMilouze14 le Mar 15 Oct 2019 - 19:18

De rien , mais ce script a été revu car je ne code pas ainsi!!
A priori, tout est fonctionnel sur la liste, le soucis et le retour des liens des images.
Ceci est dû au lien que tu génères autour des images:

https://forum.forumactif.com/t401171-encadrement-des-image-via-js#3348017

En fait désormais sur ton fofo, on ne trouve plus des images avec ce code html:
Code:

<img src="lien de l image"/>

Mais ceci:



Code:

<a href="lien de l image">

Voilà pourquoi, le script n'agit plus Stéphane
fascicularia
fascicularia
Milouzien

Messagefascicularia le Mar 15 Oct 2019 - 19:23

re Philippe,
je teste de suite avec un petit vidage des caches avant.
Milouze14
Milouze14
Fondateur

MessageMilouze14 le Mar 15 Oct 2019 - 19:25

Hum, je n'ai rien modifié mon ami,
çà devient quasi impossible de modifier quoique ce soit désormais.....


Le respect mutuel est le fondement de la véritable harmonie.(Dalaï Lama).
fascicularia
fascicularia
Milouzien

Messagefascicularia le Mar 15 Oct 2019 - 19:31

re Phiippe,

un soucis lié au fait que je me sois connecté ?
Milouze14
Milouze14
Fondateur

MessageMilouze14 le Mar 15 Oct 2019 - 19:36

Re Stéphane,
non non cela n'a rien a voir ..

Le script cherche une image et désormais il trouve un lien à cause du sujet en cours sur le forum des forums.
Il va falloir faire un choix entre les deux scripts Stéphane car on se base aujourd'hui
sur des liens et non plus sur des images d'un côté et des liens de l'autre...
fascicularia
fascicularia
Milouzien

Messagefascicularia le Mar 15 Oct 2019 - 19:42

Je comprends.
Bon, je vais supprimer le script d'affichage des vignettes qui est de la fioriture. l'autre script sert à palier un défaut de visualisation des images  lié à la fainéantise de certains membres qui oublient de mettre les balises img.

Merci pour ton aide
Milouze14
Milouze14
Fondateur

MessageMilouze14 le Mar 15 Oct 2019 - 19:46

Oui c'est assez navrant, désolé, mais là c'est du domaine de l'impossible ...
De rien Stéphane.


Hello


Sujet résolu et déplacé dans le forum adéquate

A bientôt pour une prochaine demande clin oeil



Le respect mutuel est le fondement de la véritable harmonie.(Dalaï Lama).

Voir le sujet précédent Voir le sujet suivant Revenir en haut

Créer un compte ou se connecter pour répondre

Vous devez être membre pour répondre.

S'enregistrer

Rejoignez notre communauté ! C'est facile !


S'enregistrer

Connexion

Vous êtes déjà membre ? Aucun soucis, cliquez ici pour vous connecter.


Connexion

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum